Web app requests and APIs are degraded

Incident Report for Aviator

Resolved

We deployed a fix to improve the queue page load performance that has resolved the performance issues.
Posted Jul 15, 2026 - 02:17 UTC

Monitoring

We have identified the root cause. This is a API request optimization issue. We have scaled up our instances and continuing to monitor. We are also preparing a fix to optimize our queries further.
Posted Jul 14, 2026 - 19:59 UTC

Investigating

The APIs are slow again. The rollback only temporarily resolved the response times, continuing to investigate.
Posted Jul 14, 2026 - 19:06 UTC

Monitoring

We have rolled back to the last stable version and monitoring the status. The system seems stable.
Posted Jul 14, 2026 - 18:45 UTC

Investigating

Queues are working properly however the dashboard and APIs are degraded. Investigating.
Posted Jul 14, 2026 - 18:26 UTC
This incident affected: Management dashboard.