Queue backed up

Incident Report for Aviator

Resolved

The incident is resolved.

Root cause: A large bulk team-reorganization in one customer's GitHub organization triggered database lock contention in our team-sync handler, which consumed the shared worker pool that processes all the background tasks.
Posted Aug 11, 2026 - 21:49 UTC

Monitoring

The queue should be operational again, we're continuing to actively monitor the situation.
Posted Aug 11, 2026 - 21:33 UTC

Update

We've deployed an initial fix, we're monitoring currently.
Posted Aug 11, 2026 - 21:27 UTC

Update

We are continuing to investigate this issue.
Posted Aug 11, 2026 - 21:16 UTC

Update

We are continuing to investigate this issue.
Posted Aug 11, 2026 - 20:43 UTC

Investigating

We are currently investigating a backed up queue. This could also cause delay in action for queueing or dequeueing a PR
Posted Aug 11, 2026 - 20:43 UTC
This incident affected: Background queues.